Groups

Group Admins
  • Profile Photo
    camille
  • Profile Photo
    Ariel Sommeria-Klein

amfPHP Users

Public Group  |  active 6 months, 2 weeks ago ago

This forum is not active anymore, please ask your questions on stackoverflow

Service browser issue– NetConnection.Call.BadVersion

Viewing 1 - 4 of 4 posts
  • Deleted User

    said

    I am trying to install amfphp but got no luck. Can any one help me?
    –windows
    — Apache http server 2.2
    — php 5.3.5
    I installed both amfphp 1.9 and 2.0

    For amfphp1.9, the url is http://23.21.201.159/amfphp_1.9/gateway.php.
    gateway file shows file but service browser(http://23.21.201.159/amfphp_1.9/browser/) has the following error msg.

    (mx.rpc::Fault)#0
    errorID = 0
    faultCode = “Client.Error.MessageSend”
    faultDetail = “Channel.Connect.Failed error NetConnection.Call.BadVersion: ”
    faultString = “Send failed”
    message = “faultCode:Client.Error.MessageSend faultString:’Send failed’ faultDetail:’Channel.Connect.Failed error NetConnection.Call.BadVersion: ‘”
    name = “Error”
    rootCause = (Object)#1
    code = “NetConnection.Call.BadVersion”
    description = “”
    details = “”
    level = “error”

    URL for amfphp 2.0 is http://23.21.201.159/amfphp/, again, the index,php works fine but the service browser is not showing. For both versions, the pizzasample doesn’t work.

    Can any one help me?

    Thank you so much.

    Xiaowen

  • Deleted User

    said

    Ariels, thanks for the prompt reply. I’ve read that page but still has no clue. Since I am just trying to open service browser, I guess I can assume there’s no bug issue in php code, and I don’t have extra characters hanging around. So, both causes listed for NetConnection.Call.BadVersion should not be applied. Where else should I check?

    Thanks

  • Ariel Sommeria-Klein

    said

    the error could happen just when you call from flash.
    regarding the missing characters:
    This is particularly tricky because it doesn’t show up in the service browser
    the service browser doesn’t mind extra characters.
    What is most likely though is a PHP error.
    try
    Use a Packet Sniffer

Viewing 1 - 4 of 4 posts
Topic tags: NetConnection.Call.BadVersion, Service browser

Warning!

This content
is outdated.

Discover Silex v2,
online website builder.

Sign up for Silex Labs news by email

SilexLabs community Tweets